Paxos - Dashboard Portal Incident Resolved

Incident Report for Paxos

Resolved

The issue has been fully resolved. Thank you for your patience.
Posted Mar 20, 2026 - 19:10 UTC

Monitoring

The issue has been resolved in the Production environment. We are continuing to work on restoring full functionality in the Sandbox environment.
Posted Mar 20, 2026 - 18:53 UTC

Identified

The root cause of the issue has been identified, and our Engineering team is in the process of deploying a fix.
Posted Mar 20, 2026 - 18:48 UTC

Investigating

We are currently experiencing an issue impacting the Dashboard portal. As a result, users may encounter errors when accessing the following pages:

API Management

Fiat Account Instructions

Crypto Deposit Address

Our Engineering team is actively investigating and working to resolve the issue as quickly as possible.

We will provide further updates as more information becomes available.
Posted Mar 20, 2026 - 18:20 UTC
This incident affected: Dashboard UI (Crypto Transfers, Fiat Transfers, Dashboard Web UI).