Paxos - Exchange Incident Detected

Incident Report for Paxos

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 21:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 21:26 UTC

Identified

Engineering is implementing a fix to ensure the impacted orders' status is displayed correctly.
Posted Nov 03, 2025 - 20:07 UTC

Investigating

We identified an issue where for some customers trading orders appear stuck in an "Open" status when customers attempt to cancel them. These orders have actually been cancelled successfully and will not be matched. Our Engineering team is working on fixing the issue.
Posted Nov 03, 2025 - 19:30 UTC
This incident affected: Paxos v2 API (Trading - Orders) and account.paxos.com UI (Trading).