Paxos - Dashboard KYC Verification Incident Detected

Incident Report for Paxos

Resolved

The issue is now resolved.
Posted Jan 08, 2026 - 16:03 UTC

Identified

We are experiencing an issue affecting KYC verification in the Paxos Dashboard. Users with sensitive roles may be unable to complete KYC verification. Our Engineering team is working on the issue.
Posted Jan 08, 2026 - 15:37 UTC
This incident affected: Dashboard UI (Dashboard Web UI).